CI: update to the latest goreleaser version

It seems like our config is still valid,
as we aren't affected by anything recent outlined in
https://goreleaser.com/deprecations/ since v1.1.0.

I ran both v1.1.0 and v1.8.2 locally via

	goreleaser build --skip-validate

and on both versions the tool appears to work.
It seems safer to stick to the latest stable version.

Change-Id: I8a11bc3820fd9a28a09b2eb86dee7cae3bd3e74d
Signed-off-by: Daniel Martí <mvdan@mvdan.cc>
Reviewed-on: https://review.gerrithub.io/c/cue-lang/cue/+/536754
Unity-Result: CUEcueckoo <cueckoo@cuelang.org>
TryBot-Result: CUEcueckoo <cueckoo@cuelang.org>
Reviewed-by: Paul Jolly <paul@myitcv.io>
diff --git a/.github/workflows/release.yml b/.github/workflows/release.yml
index 5955a6d..8fe5684 100644
--- a/.github/workflows/release.yml
+++ b/.github/workflows/release.yml
@@ -34,7 +34,7 @@
         uses: goreleaser/goreleaser-action@v2
         with:
           args: release --rm-dist
-          version: v1.1.0
+          version: v1.8.2
         env:
           GITHUB_TOKEN: ${{ secrets.CUECKOO_GITHUB_PAT }}
       - name: Re-test cuelang.org
diff --git a/cmd/cue/cmd/testdata/script/cmd_github.txt b/cmd/cue/cmd/testdata/script/cmd_github.txt
index b2520c2..a79f1a9 100644
--- a/cmd/cue/cmd/testdata/script/cmd_github.txt
+++ b/cmd/cue/cmd/testdata/script/cmd_github.txt
@@ -83,7 +83,7 @@
         uses: goreleaser/goreleaser-action@v2
         with:
           args: release --rm-dist
-          version: v1.1.0
+          version: v1.8.2
         env:
           GITHUB_TOKEN: ${{ secrets.CUECKOO_GITHUB_PAT }}
       - name: Re-test cuelang.org
@@ -1259,7 +1259,7 @@
 			uses: "goreleaser/goreleaser-action@v2"
 			with: {
 				args:    "release --rm-dist"
-				version: "v1.1.0"
+				version: "v1.8.2"
 			}
 		}, _#step & {
 			_#arg: {
diff --git a/cue/testdata/eval/github.txtar b/cue/testdata/eval/github.txtar
index a210792..42ccd1e 100644
--- a/cue/testdata/eval/github.txtar
+++ b/cue/testdata/eval/github.txtar
@@ -191,7 +191,7 @@
 			uses: "goreleaser/goreleaser-action@v2"
 			with: {
 				args:    "release --rm-dist"
-				version: "v1.1.0"
+				version: "v1.8.2"
 			}
 		}, _#step & {
 			_#arg: {
@@ -1413,7 +1413,7 @@
                 uses: (string){ "goreleaser/goreleaser-action@v2" }
                 with: (#struct){
                   args: (string){ "release --rm-dist" }
-                  version: (string){ "v1.1.0" }
+                  version: (string){ "v1.8.2" }
                 }
               }
               6: (#struct){
@@ -1925,7 +1925,7 @@
             uses: (string){ "goreleaser/goreleaser-action@v2" }
             with: (#struct){
               args: (string){ "release --rm-dist" }
-              version: (string){ "v1.1.0" }
+              version: (string){ "v1.8.2" }
             }
           }
           6: (#struct){
@@ -2414,7 +2414,7 @@
             uses: "goreleaser/goreleaser-action@v2"
             with: {
               args: "release --rm-dist"
-              version: "v1.1.0"
+              version: "v1.8.2"
             }
           }),
           (〈4;_#step〉 & {
diff --git a/internal/ci/workflows.cue b/internal/ci/workflows.cue
index 21226f9..1810c29 100644
--- a/internal/ci/workflows.cue
+++ b/internal/ci/workflows.cue
@@ -252,7 +252,7 @@
 				uses: "goreleaser/goreleaser-action@v2"
 				with: {
 					args:    "release --rm-dist"
-					version: "v1.1.0"
+					version: "v1.8.2"
 				}
 			},
 			_#step & {