PreciousPie

- Linux version 3.18.118
- Merge August ASB tag
- Update AnyKernel2 to latest from osm0sis
- Support preshus pie :3
Merge tag 'ASB-2018-08-05_3.18-o-mr1' into XOS-8.1

https://source.android.com/security/bulletin/2018-08-01
CVE-2017-18249*
CVE-2018-9465
CVE-2018-9439
CVE-2018-1068

* currently no 4.4 backports exist for CVE-2017-18249 on android-4.4
  release branches. This affects only devices using f2fs running
  4.4 kernels.

* tag 'ASB-2018-08-05_3.18-o-mr1':
  netfilter: ebtables: CONFIG_COMPAT: don't trust userland offsets
  FROMLIST: binder: fix proc->files use-after-free
  x86/MCE: Serialize sysfs changes
  scsi: sg: don't return bogus Sg_requests
  futex: Prevent overflow by strengthen input validation
  usb: gadget: f_hid: fix: Prevent accessing released memory
  futex: Remove requirement for lock_page() in get_futex_key()
  usb: gadget: define free_ep_req as universal function

Signed-off-by: Harsh Shandilya <harsh@prjkt.io>