| # Port: devel/check |
| pkgname=check |
| pkgver=0.11.0 |
| pkgrel=1 |
| pkgdesc="A unit testing framework for C" |
| arch=('i386' 'amd64') |
| url="http://check.sourceforge.net/" |
| license=('LGPL') |
| install=$pkgname.install |
| source=(https://codeload.github.com/libcheck/check/tar.gz/${pkgver}?dummy=/libcheck-check-${pkgver}_GH0.tar.gz) |
| |
| build() { |
| cd $pkgname-$pkgver |
| |
| autoreconf -vi |
| |
| ./configure --prefix=/usr --disable-static |
| gmake |
| } |
| |
| package() { |
| cd $pkgname-$pkgver |
| gmake DESTDIR="$pkgdir" install |
| |
| # get rid of the package's info directory, |
| # install-info adds entries for us at install-time |
| rm "$pkgdir/usr/share/info/dir" |
| |
| # svn log file is too big |
| rm "$pkgdir"/usr/share/doc/check/*ChangeLog* |
| |
| } |
| md5sums=('34575790da139542a6cb0517237751ca') |