blob: 54eaa86cf54df59f37d11f8e403b523a40fcdc91 [file] [log] [blame]
# Port: devel/check
pkgname=check
pkgver=0.12.0
pkgrel=1
pkgdesc="A unit testing framework for C"
arch=('i386' 'amd64')
url="http://check.sourceforge.net/"
license=('LGPL')
install=$pkgname.install
source=(https://codeload.github.com/libcheck/check/tar.gz/${pkgver}?dummy=/libcheck-check-${pkgver}_GH0.tar.gz)
sha256sums=('7816b4c38f6e23ff873786f18d966e552837677bfae144041e0587e7c39e04e8')
build() {
cd $pkgname-$pkgver
autoreconf -vi
./configure --prefix=/usr --disable-static
gmake
}
package() {
cd $pkgname-$pkgver
gmake DESTDIR="$pkgdir" install
# get rid of the package's info directory,
# install-info adds entries for us at install-time
rm "$pkgdir/usr/share/info/dir"
# svn log file is too big
rm "$pkgdir"/usr/share/doc/check/*ChangeLog*
}